1st post - installation help please. Ubuntu - 3.1.0


#1

Hi all. **Solved! Turn off apparmor to keep service running.

Ok update 2. It appearss Ubuntu server 9.04 is better at running Nagios with appamor turned off but after several days i have 2 installs doing the same thing. Sometimes the nagios just wont start. Generally if the server is rebooted it loads. But doing a /etc/init.d/nagios restart wont restart the service. It cant kill the service pid as it isnt running and it appears to start ok but /etc/init.d/nagios status shows it isnt running Can only think to reformat one and remove the ext4 file system as i know it worked in 8.1 server with ext3 file system!! Seems to be a process of elimination and very frustrating! However for a newchum i now know much more from trying to solve this problem than if it had just worked ok

update 2 - after reformat in ubuntu 9.04 with xfs i am having no trouble with nagios 3.1.0.
Interesting i tried cvs version in ubuntu 9.04 with ext4 and had same problems

update 3. problems returned to keeping the service running in ubuntu 9.04 nomatter what i do. No other program appears to have problems! back to 8.1 and it runs 100% fine and reliable as expected it should work. Set another hdd up for 9.04 and did a basic install, then nagios and the service wont start. I says nagios is running then whn you do a /etc/init.d/nagios status it says its not running (also verified in ps-e listing) Nothing in nagios logs or other logs but as a beginner need to find and look at the syslogs area i think)

anyway the hdd with 8.1 just purrs a long. Wonder what the problem is.

Is anyone with ubuntu 9.04 and nagios working can comment?

**

After having nagios 3.1 installed and reformat and reinstall OS (ubuntu server cd) and having reasonable good succsess) i have hit a brick wall. Thought i ,must have been getting smart enough to just remove files and not have to reformat again!

I installed again and could not get the web page up. Then i could get the web page up at 192.168.1.101/nagios to load but it looked like the service wasnt running. Side bar is present, but nothing related to other pages.

I did a rm /usr/local/nagios -f -r and cjhecked it had all gone. then started install again but same result. However i must have stuffed a user or user name.

When i run /etc/init.d/nagios stop it says kill 200 nothing to kill. then /etc/init.d/nagios start and it appears to start ok.
looking in the nagios log it appears to load with out error but the daemon isnt running as far as i can see.
is there a demon in the machine?

Any clues please?
did a ps -e and cant see nagios running as a service at all. did a /etc/init.d/nagios start, message says nagios started. did ps -e and still no sign.

I then did a /etc/init.d/nagios start then /etc/init.d/nagios status and it says nagios is running but a second later i repeat and it says nagios is not running. same check config says its all ok. a main config check with /user /local/nagios/nagios -v /usr/local/nagios/etc/nagios.cfg also comes back with no errors.

Learning all the time but camt make it stay working.

i am basic noobie and cant find the light switch! can anyone suggest anything? thanks.

I have again remove (what i think is everything and same result.)

rm the /usr/local/nagios and all in here by rm /usr/local/nagios -r-f
userdel the nagios and nagcmd users. groupdel the nagios and nagcmd groups.
Gone through the install proceedure again and all appears to install ok and yet when get up web interface it doesnt ask for login info and the nagios service doesnt seem to start.

When try /etc/init.d/nagios restart it complains there is no pid to kill and yet appears to start ok.

In the web interface i can see the log

ps -e and no nagios, /etc/init.d/nagios start and it says nagios started. then ps -e and still no sign. What next please?

ok i ** believe the problem is in Ubuntu 9.04 as i did a 8.1 server install and it worked ok. Now i am redoing an install with 8.1 and will see what happens. Clean install on 9.04 server and standard nagios ubuntu install and the nagios service fails to stay operating. it appears to start but shut down for some reason. **

[1240047292] Finished daemonizing… (New PID=509)
[1240047356] Nagios 3.1.0 starting… (PID=591)
[1240047356] Local time is Sat Apr 18 19:05:56 CST 2009
[1240047356] LOG VERSION: 2.0
[1240047356] Finished daemonizing… (New PID=592)
[1240047705] Nagios 3.1.0 starting… (PID=4581)
[1240047705] Local time is Sat Apr 18 19:11:45 CST 2009
[1240047705] LOG VERSION: 2.0
[1240047705] Finished daemonizing… (New PID=4582)
[1240047834] Nagios 3.1.0 starting… (PID=4635)
[1240047834] Local time is Sat Apr 18 19:13:54 CST 2009
[1240047834] LOG VERSION: 2.0
[1240047834] Finished daemonizing… (New PID=4636)
[1240047839] Nagios 3.1.0 starting… (PID=4667)
[1240047839] Local time is Sat Apr 18 19:13:59 CST 2009
[1240047839] LOG VERSION: 2.0
[1240047839] Finished daemonizing… (New PID=4669)


#2

HI!
I have EXACTLY the same problem of you.
I have performed a double upgrade from 8.04 to 810 and then from 8.10 to 9.04.
Nagios works fine till 8.10, but now it do not start anymore.

The check show no problem, but the process isn’t active even if the start command says “done”!

If you find a solution please post it here.

I have also open a BUG report here:
bugs.launchpad.net/ubuntu/+bug/372633

ciao!
PiCo


#3

Hi Guys,

Please try to debug nagios with gdb and find what causes the problem.

Regards,