404 web interface please help


#1

I have gotten through the installation until I hit setting up the web interface, this simply does not want to work here is what I added to my httpd.conf , please let me know if there is anything wrong with what I’ve added…

ScriptAlias /nagios/cgi-bin “/usr/local/nagios/sbin”
<Directory “/usr/local/nagios/sbin”>
Options ExecCGI
AllowOverride AuthConfig
Order allow,deny
Allow from all

HTML Allowment for NAGIOS

Alias /nagios/ “/usr/local/nagios/share”
<Directory “/usr/local/nagios/share”>
Options None
AllowOverride AuthConfig
Order allow,deny
Allow from all

Thanks guys


#2

Your config looks fine, so check your basics:

  1. Make sure apache is running.
  2. Make sure the aliases you created point to the right directories as intalled on your system.

If that doesn’t work, I’d try checking your apache error log and then using the search function on the forum for your particular error.


#3

That’s what I don’t understand, All the folders are there, the config looks fine, I have no idea why apache can’t find the file, even if I go localhost/nagios/index.html still gives me the ole 404


#4

Yeah, you won’t be able to access any of the html files until you can get yourself into that localhost)?
If you can get to the home page then try getting to localhost/nagios/ again and check the last few lines of your error_log file for apache.


#5

here’s what I CAN and can’t do, I CAN’T use simply localhost however, I have the documentroot set to /home/nagios/public_html
so I CAN use localhost/~apache, they both work. So if that tells you anything…


#6

I’m getting this [Wed Nov 23 15:55:33 2005] [error] [client 142.166.171.176] File does not exist: /srv/www/htdocs/nagios
[Wed Nov 23 15:55:38 2005] [error] [client 142.166.171.176] File does not exist: /srv/www/htdocs/nagios
[Wed Nov 23 16:03:48 2005] [error] [client 127.0.0.1] File does not exist: /srv/www/htdocs/nagios
[Wed Nov 23 16:33:48 2005] [error] [client 127.0.0.1] File does not exist: /srv/www/htdocs/nagios
how do I stop it from trying to service requests from /srv/www/htdocs?


#7

Is there any specific place in http.conf that these entries have to be?


#8

the http request is being directed to the directory /srv/www/htdocs/nagios you need to find the entry for the main directory of the nagios htdocs part and point it to share subdirectory in nagios. CHeck the docs again for setting up the web interface. :wink:

Luca


#9

Should the alias that I set up in http.conf be directing it to /usr/local/nagios/share? Why the hell is is trying to service the request from /srv/www/htdocs/nagios?


#10

because that is probably the default directory of your web server…
looks like you are missing something in the “nagios homepage” setup. as i said check the docs again for setting up the webinterface :slight_smile:

Luca


#11

nothing was actually wrong with the config, the problem was there was 2 different instances (and configs) of apache running :o I was wondering why the changes to the config weren’t doing anything ahaha! Thanks guys.


#12

:slight_smile: