Access Nagios from another workstation


#1

Hi guys. I am sort of very new to Linux and Nagios and i cant tell you the amount of times i have tried to pick up Linux and Nagios and failed. Anyway i am back for some more punishment. Please note i am not a 100% noob as i am a network analyst with many certifications but with Linux i am a bit stuck.

Anyway i have followed the install notes from http://nagios.sourceforge.net/docs/3_0/quickstart-fedora.html and have to say it has gone very well this time round with no major problems along the way.

I am running fedora 9 with the latest version of Nagios + the plugin. I have disabled the firewall and have also switched off SELinux.

The problem i have is i can only access the Nagios main page from the server it is installed on by going to localhost/nagios if i try to access it from another workstation i get a Failed to Connect

Firefox can’t establish a connection to the server at 192.168.101.5.

Any ideas as to what i can do to fix this issue?

Many thanks for any help you can give

Craig


#2

Dumb question maybe but what do you get from: ps -aef|grep httpd


#3

Hi,

good news that you are a network analyst, because, to me, it seems you’re stuck in a network problem…

Could you do some tests, from the machine you’re trying to get the web interface on:
telnet 192.168.101.5 80
telnet 192.168.101.5 22
traceroute 192.168.101.5
ping 192.168.101.5
…etc

everything you can think of;
maybe you’ll see something wrong (routing problems on the remote machine, routing problem back from the nagios host, firewalls, ACLs …; there are quite a lot of things that could go wrong :))


#4

I would say that 'Loose’s and my suggestions cover the bets.

  1. Either the httpd has a problem
  2. or the network has a problem.

Given that the localhost/Nagios did work, then Loose’s suggestion is likely to be true but do run the ‘ps’ command and check for config errors and or port contention by other httpd’s that might be running.


#5
  1. Open vi /etc/httpd/conf.d/nagios.conf
  2. Make sure " Allow from all" is enabled under this.
  3. to reflect changes , service httpd restart