Anyone managed to get 2.0 to work with the minumum template


#1

I have been running 1.2 for over a year, decided to upgrade to the latest - nothing worked so I had to roll back to 1.2. Then started testing and 2.0 would not even run with the supplied minimal example file. Of course ideally it would work with me extensive configuration files from 1.2 but that is more of a utopian goal - at the moment I just want to see 2.0 start with no errors and I am stuck?

If anyone could publish a set of cfg files - anything at all, even an emplty set but one that allows 2.0 to run I will really appreciate it. I was hoping on an easy upgrade but who am I fooling!

Thanks to everyone
~B


#2

I actually got Nagios to run on the minimal file supplied by Nagios. I had to tweak a few things in Nagios.cfg to get it working right, but it worked eventually. Do you get any errors when running

/usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg?


#3

Yes I get all kinds of funky errors about invalid variables, etc. I went to fix 2 which was sufficient to discover that it will be an endless monkeying around so I decided to ask the experts instead - what modifications did youhave to make to your file in order to get nagos 2.0 running? Could you be more specific so I can do the same


#4

I think you will really need to get rid of the errors when verifying your config first before every getting anything to work. Could you post the errors?


#5

Basically, I had to comment out all cfg_file lines in Nagios.cfg except for the one pointing to the minimal file. But this might not be your problem. Can you post errors? We’ll be more able to identify your problem that way.


#6

Please see my sticky on the top of forum for your solution.
meulie.net/e107_plugjes/foru … c.php?6194
The simplest thing to do, is to ditch the minimal.cfg and create all seperate files, like you had in v1.2.

I too just updated to v2.x and found minimal.cfg to be junk and SHOULD have worked right out of the box, since it was defined in nagios.cfg as a file to be used.