Authentication Fails


#1

Hi,

This is the first time that I’m using Nagios. I setup Nagios on Red Hat 9.0 - Apache/2.0.40

I added the user to htpasswd.users but when I go to myip/nagios the authentication fails… Any idea?

Regards,


#2

My guess is that you haven’t configured the user in htpasswd.users to be able to view or execute any commands via the web interface. In cgi.cfg you’ll see lines like:

authorized_for_service_information=

after which there will be a comma-delimited list of any users you want to have access to those things. Make sure also that, if the user you’ve added to htpasswd.users is already there, that there is no # in front of the line, as this will comment out that configuration option.
Edited Tue Feb 14 2006, 09:07PM ]


#3

Thanks for the reply… yes I added authorized_for_system_information=nagiosadmin but still the same thing

I have also added the followings:

authorized_for_system_commands
authorized_for_configuration_information
authorized_for_all_hosts
authorized_for_all_host_commands
authorized_for_all_services
authorized_for_all_service_commands


#4

it was a permission issue on the htpasswd.users

all good now

Thanks