Authentication problems



When I log into the nagios web browser using one of my authenticated users I get the error “It appears you do not have permission to view information for any of the services you have requested.” This is very odd because I have followed the procedures in the documentation. I have modified my cgi.cfg file and set “use_authentication=1” and I have added the configured users to the authorization settings in there. I have also added the users and they are in the .htpasswd.users file. My httpd.conf file also looks good so I am stumped as to what it could be. Does anyone have any suggestions before I throw myself out of the window ?



Follow the procedures step by step again. Check for commas, spaces or slashes out of place.

Murphy is out there waiting for you… :smiley:

Edited Thu Sep 29 2005, 08:20PM ]


This could be as simple as “did you restart httpd?” But without further info, dunno exactly.
Luca’s answer is the only good one. Do it again from top to bottom.


I have exactly the same problem and the LOGIN AS field shows ‘?’ on the screen. It seems that the CGI did not get my login username.


but in you case authentication is working isn’t it? (i had the same problem too once i installed but can’t remeber what th eproblem was… :confused: )
As above, check the authentication info… sorry.



If you followed the instructions to the letter, then you have a typo in your httpd setup or the nagios cfg’s, or perhaps you didn’t restart the webserver or nagios.

Check for typos because the docs are perfect on this matter.
Oh, and turn off your selinux firewall until you figure this out.


Thanks for your help everybody. I couldn’t find a typo in my config but I scrapped it and started again and it now works fine so there must have been a dodgy character in there somewhere.


Once again, a perfect example of “Just start from the beginning”. I compiled nagios over and over trying to fix things that were not even broke, like the ol’ “why don’t the host status’ change” thing. It’s not real hard and in this case, it can fix your troubles. When you first install it, you really don’t know what’s going on. But by now, you have a better idea and you actually watch the ./configure and make output more closely for errors.

Good job!!


If such simple mistake of blank or invisible character is possible with Nagios, I would conclude that error checking on nagios is not very good. Such invisible characters should be detected when a check was done.

My problem is actually not solved. I installed it from RPM which put most of the config together. I wish there is a way to easily debug it.
My setup actually allowed me to login but the Login As field says ‘?’ as username. Putting “use_authentication=0” shows that everything works but this is not the right thing to do.


Sorry for double posting. I found the source of the problem and the answer to this problem. Please see:


HIs problem was not a missing character but a compile/install problem. It could have been as simple as him compiling for db support and then not having the db setup. Who knows. But to critisize nagios for not finding his problem is … ludicrous. The -v option can find many problems with your .cfg files, but it isn’t about to make sure you know how to setup a web site.