Authentication subdirectory problem


#1

Hi,
I have the authz apache configuration working, but it asks for a password again every time a user goes to a subdirectory under the main one. So navigation is painful for my users and they say nagios sux. Nagios is great, I sux :slight_smile: but hoping you can change that.

so it asks for a password when we get to /usr/local/nagios/share and again when they navigate to /usr/local/nagios/share/nexsm and again if they go to /usr/local/nagios/share/nagvis and again and again for other folders under there. here’s a snippet of my httpd.conf

<Directory “/usr/local/nagios/share”>
Options Indexes
AllowOverride All
Order allow,deny
Allow from all
AuthzLDAPAuthoritative Off
AuthLDAPBindDN "user@yourdomain"
AuthLDAPBindPassword
AuthType Basic
AuthBasicProvider ldap
AuthName "Windom1 account login"
AuthLDAPURL "ldap://:3268/?sAMAccountName?sub?(memberOf=CN=<yourgroup. . . >)"
Require valid-user

is there anything I can to to say just authenticate once and then not again on any subdirectory?

thanks

adam