Blank perfdata: not parsing macros


#1

Hi,

I have nagios3 running (installed via apt-get on Debian). Everything worked pretty well until I tried to add graphing support.

As described in numerous how-tos, I added the following to nagios.cfg:

process_performance_data=1 service_perfdata_file=/usr/local/nagios/var/service-perfdata service_perfdata_file_template=$LASTSERVICECHECK$\t$HOSTNAME$\t$SERVICEDESC$\t$SERVICESTATE$\t$SERVICEATTEMPT$\t$SERVICESTATETYPE$\t$SERVICEEXECUTIONTIME$\t$SERVICELATENCY$\t$SERVICEOUTPUT$\t$SERVICEPERFDATA$\n service_perfdata_file_mode=a service_perfdata_file_processing_interval=30 service_perfdata_file_processing_command=process-service-perfdata

and kept the default value for the service-perfdata in commands.cfg:

define command{ command_name process-service-perfdata command_line /usr/bin/printf "%b" "$LASTSERVICECHECK$\t$HOSTNAME$\t$SERVICEDESC$\t$SERVICESTATE$\t$SERVICEATTEMPT$\t$SERVICESTATETYPE$\t$SERVICEEXECUTIONTIME$\t$SERVICELATENCY$\t$SERVICEOUTPUT$\t$SERVICEPERFDATA$\n" >> /var/lib/nagios3/service-perfdata.out }

The trouble is that file /usr/local/nagios/var/service-perfdata remains blank (but it does get created), while /var/lib/nagios3/service-perfdata.out gets filled with:

Glass is the name of localhost. There is a dozen other servers that nagios monitors, yet they don’t show up in the service-perfdata.out file at all. It looks like macros ($LASTSERVICECHECK$, $SERVICEOUTPUT$) do not get recognized, but there may be other things going on that I have not identified.

All other features of nagios seem to be working fine. Macros definitely work in other commands.

Any help is greatly appreciated. If you need any other diagnostic info, I will provide it promptly.