Can´t configure Hosts


#1

Hello,need help

I´m a noob to nagios.I´ve just finished installing it and I´ve tried to configure a new host in hosts.cfg but nagios doesn´t seem to call hosts.cfg.

I´ve went to nagios.cfg and I found that all the cfg´s with the excepetion of localhost.cfg are in commentary.

I tried to remove the ´#´ but when i restart nagios it says there´s a configuration error. I don´t know what I´m doing wrong

Any suggestions/solutions are apreciated
Thkx


#2

have you tried?:
nagios -v /usr/local/nagios/etc/nagios.cfg

What does it output?


#3

My only suggestiong is that you paste the error next time, instread of making us guess at what it was.

I’ll take a wild guess, that nagios is telling you it can’t find any hosts, services, etc. in any configs.
That’s because you haven’t told nagios where all your config files are located.
Here is what part of my nagios.cfg looks like. I’d strongly suggest you do the same.

cfg_file=/usr/local/nagios/etc/checkcommands.cfg

# Misc commands (notification and event handler commands, etc)
cfg_file=/usr/local/nagios/etc/misccommands.cfg

# You can split other types of object definitions across several
# config files if you wish (as done here), or keep them all in a
# single config file.

#cfg_file=/usr/local/nagios/etc/minimal.cfg

cfg_file=/usr/local/nagios/etc/contactgroups.cfg
cfg_file=/usr/local/nagios/etc/contacts.cfg
cfg_file=/usr/local/nagios/etc/dependencies.cfg
cfg_file=/usr/local/nagios/etc/escalations.cfg
cfg_file=/usr/local/nagios/etc/hostgroups.cfg
cfg_file=/usr/local/nagios/etc/servicegroups.cfg
cfg_file=/usr/local/nagios/etc/hosts.cfg
cfg_file=/usr/local/nagios/etc/services.cfg
cfg_file=/usr/local/nagios/etc/timeperiods.cfg

# Extended host/service info definitions are now stored along with
# other object definitions:
cfg_file=/usr/local/nagios/etc/hostextinfo.cfg
cfg_file=/usr/local/nagios/etc/serviceextinfo.cfg

#4

Jakkedup,like i said before I´ve already went to that part of nagios.cfg and all my cfg_files have a # behind them…I´ve tried to remove the comentary to tell nagios where he can find the cfg´s but when i stop nagios and run it again all i get is this message:

CONFIG ERROR! Start aborted. Check your Nagios configuration.


#5

What error do you get when you verify your nagios configuration files. If you don’t know how to verify your files, then please read the nagios docs starting from here:
nagios.sourceforge.net/docs/2_0/
In there, you will be instructed on how to verify your files, BEFORE you attempt to start nagios. But apparently, you decided to skip that part? The verify will tell you EXACTLY what is wrong with your files.