Cant locate config error


#1

I’m running into an interesting issue, nagios was running fine before I rebooted my system after the reboot I receive the following when trying to start nagios.

Starting nagios:CONFIG ERROR! Start aborted. Check your Nagios configuration.

however when I run /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg to try and locate where the error is located I receive:

Total Warnings: 0
Total Errors: 0

Things look okay - No serious problems were detected during the pre-flight check

any ideas on how I can locate the problem?


#2

Make sure the cfg_file= entries in your nagios.cfg are correct.

Make sure your init script for nagios is actually pointing at the proper nagios.cfg. I see you’re running -v /usr/local/nagios/bin/nagios.cfg , is that the correct nagios.cfg that you’ve been editing? does it have the correct paths to your cfg_files? is that the nagios.cfg your init script is looking for (look in /etc/init.d/nagios mos tlikely)?

Sometimes people will compile nagios to have all the configs in /etc/nagios instead of /usr/local/nagios/bin/nagios, or some package will create multiple directories. make sure mlocate is installed, then type “updatedb” then “locate nagios.cfg” and be sure you only get one result!

hope this helps


#3

See the strange thing is my nagios install will be running fine the only change I made was to an email address in a contacts.cfg file located in a cfg_dir. the strange thing is I can comment out the line in the dir I made the changes in and nagios will still not restart.