Can't view info in Web UI


#1

Hi, I recently got Nagios installed and it seems to be working fine. I have a problem accessing the web admin area though. I have a user called “nagiosadmin” and I can log in and get to the main screen, but I get the following error when I try to view any other screen:

I have set all the “authorized_for…” configurations options in cgi.cfg to allow nagiosadmin, including

authorized_for_all_services=nagiosadmin
authorized_for_all_hosts=nagiosadmin

Still no go though. Could this be an issue with file ownership or incorrect permissions? Please advise.

Thanks in advance for any help you can offer.


#2

One thing I noticed which may give a clue is that when I’m in the “Tactical Overview” screen, the top-left box shows me logged in as “?”

[quote]Tactical Monitoring Overview
Last Updated: Wed Dec 29 14:53:25 EST 2010
Updated every 90 seconds
Nagios® Core™ 3.2.3 - www.nagios.org
Logged in as ?[/quote]

Does this mean that for some reason, I’m not being recognized as nagiosadmin? If so, what could the reason(s) be?

Thanks again!


#3

OK, I figured it out - .htaccess wasn’t being read properly by Apache (well actually I accidentally named it htaccess).

I’ll let you know about the next problem I run into :).