Cgi-bin setup


#1

Where can I tell my nagios/apache setup to look for the cgi files in the cgi-bin folder instead of the cgi-gin folder? I must have keyed in cgi-gin instead of cgi-bin on the setup and I can’t find which file I need to edit to make the correction. Thanks for any help.

Regards,
Marty


#2

I am running Apache 2.2.8 on Fedora Core 7 and the config is in /etc/httpd/conf.d/nagios.conf

Find the offending cgi-gin line, replace and restart apache and nagios.

-peter


#3

I have a nagios.cfg file located in my /usr/local/nagios/etc folder but I don’t have a nagios.conf file anywhere on the system. I’m on Debian 4.1 running Nagios v3.0.

  • marty

#4

I reran the ./configure option with the correct path and then reran all of the make install commands. This resolved the problem. I still don’t have a nagios.conf file but I do have a nagios.cfg file. I would presume these do the same thing.

  • marty

#5

The nagios.cfg file is the nagios config file. The nagios.conf file I was referring to is the site definition that apache uses. You might not have this file, but I am sure you have the definition somewhere. grep your apache’s etc directory for nagios and you will probably find what I was talking about originally.
But if a reconfigure fixed it, all is well!

-peter