CGI-BIN wasn't created


#1

Run the Configure Script:
./configure --prefix=/usr/local/nagios --with-cgiurl=/nagios/cgi-bin --with-htmurl=/nagios/ --with-nagios-user=nagios–with-nagios-group=nagios --with-command-group=nagios
i run by above settings.
and make all
make install
but i coudn’t find cgi-bing folder.all .cgi files are in sbin.when i run application by web interface,when i click links at left side it is displaying following error:
Not Found
the request URL /nagios/cgi-bin/status.cgi was not found on this server

what i did is :
i created cgi-bin folder in install dir/share folder and copied all .cgi files to cgi-bin folder.
then right frame displaying following error.

Error: Could not read object configuration data!
1 Verify configuration options using the -v command-line option to check for errors.
2 Check the Nagios log file for messages relating to startup or status data errors.
3 Make sure you’ve compiled the main program and the CGIs to use the same object data storage options (i.e. default text file or template-based file).
1->it is ok
2->no log file is being create
3->i coudn’t understand what is this meaning

please provide the solutions to my problem
thank you


#2

The problem is that you didn’t follow the nagios installation instructions very well.
Please try again.
nagios.sourceforge.net/docs/2_0/
Even after installing nagios dozens of times, I still follow them word for word, and then make a few corrections that I have documented in this forum.
meulie.net/portal_plugins/fo … c.php?6194