CGI not found


#1

Ok, i have looked all over and tried everything it seems and its still not working. I have installed nagios 2.0b4 on CentOS 4 with apache 2. I followed the instructions exactly and it didnt work. I authenticates users and you can view the “home” and “documentation” pages but all the rest(which are all cgi) it comes up with the “page not found” error stating that “The requested URL /nagios/sbin/anyfile.cgi was not found on this server. Apache/2.0.52 (CentOS) Server at 10.10.200.112 Port 80” where “anyfile” is any of the cgi files. I have temporarily disabled the SElinux features after reading how that can cause issues until i can get this figured out. I have checked all file permissions and it looks good. All links and aliases in the config files are headed to the right destinationas far as i can tell. My apache error log says the following when i try and access a page:

“[Wed Aug 31 15:52:26 2005] [error] [client 10.10.200.115] File does not exist: /usr/local/nagios/share/sbin, referer: 10.10.200.112/nagios/side.html

Now, this is true because the sbin folder is a directory up from that which is also set in the config files. When i stry and start the nagios service i get the following:

“[root@sam-dev logs]# /etc/rc.d/init.d/nagios start
Starting network monitor: nagios
CONFIG ERROR! Start aborted. Check your Nagios configuration.
[root@sam-dev logs]#”

I have checked the files and i am now sitting here staring at my computer and the nagios website because i have no idea where to go next. Any help would be appreciated.

*nagios.cfg file attached as .txt

[file=e107_files/public/7101_nagios.txt]7101_nagios.txt[/file]


#2

…and the cgi.cfg file as txt

[file=portal_files/public/7101_cgi.txt]7101_cgi.txt[/file]


#3

The entry you made in the httpd.conf was made incorrectly. It should have been
ScriptAlias /nagios/cgi-bin/ /usr/local/nagios/sbin/
<Directory “/usr/local/nagios/sbin/”>
AllowOverride AuthConfig
Options ExecCGI
Order allow,deny
Allow from all


#4

I have the same problem with nagios 2.0b4 on CentOS 4 with apache 2. but my scriptAlias matches what else could be the problem???


#5

my error is The server encountered an internal error or misconfiguration and was unable to complete your request.


#6

Most likely, you have a config file problem. Run the nagios check FIRST, with the -v option.


#7

I am running CentOS 4 with Apache 2 and I have the same problem. According to /var/log/messages:

Oct 16 17:41:17 NMS kernel: audit(1129498877.950:41): avc: denied { execute } for pid=7625 comm=“httpd” name=“s
tatus.cgi” dev=dm-0 ino=5686929 scontext=root:system_r:httpd_t tcontext=root:object_r:usr_t tclass=file

So, it’s failing trying to read the CGI’s…I’m not sure why at this point.

Any help is appreciated.


#8

The problem is with SE Linux…I went into grub and disabled it, rebooted, and everything is working fine.

Hope this helps.