check_external_command cuases Nagios to crash?


#1

Build a nagios on my Suse and its working fine. This app rockz. Then i used a Debian machine and did the same thing nagios is up and running very well. The only problem was that when i enable the external_commands in the nagios.cfg. The programs refuse to start. I says nagios starting…, but when i do a “ps aux | grep nagios”, there is nothing running. Also tried doing echos on the script, the programs does runs into the case where nagios starts. However nagios doesnt starts.

???

Plz! Need advice.


#2

setup proper permissions on your RW directory. This is the ONLY directory/files that have permissions UNLIKE ANY of the other files/directories.


#3

and check the logs possibly you get some more info about the error causing this. :slight_smile:

Luca


#4

another thing would be to use the -v option to verify the configs BEFORE you try to start nagios. The -v just might tell you exactly what is wrong with your nagios.cfg file. Most likely, it’s a typo when you tried to enable external commands.