check_fping returns "Warning" Status


#1

Hi All,

I recently started using check_fping instead of check_ping based on some recommendations on the forum. When I run check_fping on the command line, I get OK status. However, a service check returns warning status. I checked owner/group permissions on the libexec dir and it is all set to nagios. Also fping has execute permissions set for others. Even though I tried different settings, the settings I currently have is

checkcommands.cfg
command_name check_fping
command_line $USER1$/check_fping -H $HOSTADDRESS$ -n 2

services.cfg
check_command check_fping

When I run check_fping on the command line, I get the following

./check_fping -H hostanme -n 2
FPING OK - hostname (loss=0%, rta=0.770000 ms)|loss=0%;;;0;100 rta=0.000770s;;;0.000000

However, as a service check, I get

Current Status: WARNING
Status Information: FPING WARNING - hostname
Current Attempt: 3/3

Any ideas on where the problem could be?


#2

I recently made a mistake and changed all the user.group permissions in the /usr/local directory and sub’s to root.root
Soooo, nagios complained like crazy and then I had all of them fixed except fping, getting the same error you now have.

So make sure your fping is like this.
-rwxrwxr-x 1 nagios nagios 49975 Jun 25 16:23 check_fping

which fping
/usr/local/sbin/fping
[[email protected] libexec]# ls -la /usr/local/sbin/fping
-rwsr-xr-x 1 root root 42379 Jun 9 09:40 /usr/local/sbin/fping

If I recall correctly, the big problem was the sticky bit on fping.


#3

Thank you jakkedup. That did it. My fping works now after setting the sgid bit for user (root).

Thanks once again.