check_mem error?


#1

When I run check_mem to check memory usage on a system, I get an error message. Not sure what would cause that. My other nrpe commands works… like check_sda1. Why would check_mem not work? Both of the commands are on the server and client side.

Here’s what I have on my nrpe.cfg for the check_mem command

command[check_mem]=/usr/local/nagios/libexec/check_mem -w 90 -c 95

When I run the command manually

sudo /usr/local/nagios/libexec/check_nrpe -H ***.***.***.*** -c check_mem -t 30
NRPE: Unable to read output

#2

can you execute it locally on the client side from command line?


#3

No, can’t run the check_mem locally.

/usr/local/nagios/libexec/check_nrpe -H localhost -c check_mem NRPE: Unable to read output


#4

i mean running /usr/local/nagios/libexec/check_mem

Luca


#5

[quote=“luca”]i mean running /usr/local/nagios/libexec/check_mem
[/quote]

I can’t find the “check_mem” on the system when running a locate command or by browsing “/usr/local/nagios/libexec” folder. Should it be some where else?


#6

how did you get it on your own server? :slight_smile:


#7

looks like I’ll just go with check_swap.

Thanks luca