Hi all!

Im kinda new to nagios and exploring things (Nagios really roxx). Found a plugin check_nmb (samba) and cant get it work. Checking nmb on a remote host. Cant do this check. ./check_nmb -H -l skupno. Must i run plugin on host, im sure there are alternatives to do this check (check_procs). i would like to do it without checking local resources if possible.

Thx for advices in advance.


I have some problems with this plugin. In shell it works fine, but in nagios it is critical and returns null. running on centos 5.3. Any ideas?


No one with same problem?


don’t know if you already found a solution, just to let you know I solved the same problem adding the -l switch (and the name of the the server to lookup for) in the nagios command definition, the script doesn’t need it if used from the command line but without it doesn’t work with nagios (I used the -v switch to debug with nagios).


Marco Bruni



thx for reply.

still doesnt work and result is still (null). I defined like that.

command[check_nmb]=path_to plugin -H $ARG1$ -l $ARG2$

service description {


still does’t do the trick…im confused
can you copy/paste the plugin code you used and plugin permissions if u can