CHECK_NRPE: Error receiving data from daemon


#1

Dear friends,

I have configured the nrpe-2.0 on my redhat ES 3 machine (means nrpe.cfg,nrpe with xinet) with ssl. My server is also redhat ES 3 containing nagios 1.4 .I have configured also services.cfg and adding hosts in that server.
When my plugin named check_oracle executed that time it is giving me error “CHECK_NRPE: Error receiving data from daemon”.

Please let me know what I have missing to configure.

Thanks in advance…
Gitesh :roll:


#2
  1. Check that the plugin runs correctly when you call it directly on the remote host.
  2. Check the following (from the Nagios FAQ at www.nagios.org)

#Different versions. Make sure you are using the same version of the check_nrpe plugin and the NRPE daemon. Newer versions of NRPE are usually not backward compatible with older versions.
#SSL is disabled. Make sure both the NRPE daemon and the check_nrpe plugin were compiled with SSL support and that neither are being run without SSL support (using command line switches).

Incorrect file permissions. Make sure the NRPE config file (nrpe.cfg) is readable by the user (i.e. nagios) that executes the NRPE binary from inetd/xinetd.

Unallowed address. If you’re running the NRPE daemon under xinetd, make sure that you have a line in the xinetd config file that say “only_from = xxx.xxx.xxx.xxx”, where xxx.xxx.xxx.xxx is the IP address that you’re connected to the NRPE daemon from.

Let us know how you get on.


#3

Yeah redtom has right.
Think to check your connection, first:
Try to connect with a telnet:

  • first local : telnet 127.0.0.1 num_port_nrpe (5666 default)
  • then from your nagios remote host
    Good luck