check_nrpe not working


I’ve just installed nrpe on solaris 10, and it’s been installed correctly, no errors during that process. however when i run:

/usr/local/nagios/libexec/check_nrpe -H localhost

I get the following

CHECK_NRPE: Error - Could not complete SSL handshake.

I configured using the following:

./configure -with-ssl=/usr/local/ssl/ -with-ssl-inc=/usr/local/ssl/include/openssl/ -with-ssl-lib=/usr/local/ssl/lib/

to ensure the ssl headers and libs were found.

Has anyone got any suggestions? Please not I’ve checked the tips on the nagios site


I’ve progressed a little with my problem

I’ve configured the nrpe plugin on the remote host and nagios server with --disable-ssl so I stop getting the handshake errors…however I get the following when run from the nagios server:

./check_nrpe -H -n -c check_users
CHECK_NRPE: Received 0 bytes from daemon. Check the remote server logs for error messages.

as a note, this is running on solaris 10


I think you may still need to put the -n in the start up for NRPE so it doesn’t try to do ssl. I know that’s true with my freebsd and linux servers.