check_nrpe: Response packet had invalid CRC32


#1

I have installed nagios 3.0 on 6 servers. The host is a SunFire V440 running Solaris 9 and the clients are 1 V440 running Solaris 9 and 4 T2000s running Solaris 10. All are configured and running nagios with the plugins utilizing nrpe (via inetd) to check the services. On this one server, I get the error identified above for every monitor – even if I execute the check locally. I ran a truss and it is looking for a file that does not exist - /var/ld /ld.config ; but this file is not present on any of the servers. I have recompiled the nagios plugins as well as nrpe and still no luck. This is the same package I used for all of the other servers.

Has anyone seen this before and can they help. I’ve checked the nagios-users lists and they do not identify a solution for my problem.

I read through some other posts where people had similar problems. But the proposed fixes did not correct my problem.


#2

osdir.com/ml/network.nagios.deve … 00004.html
forums13.itrc.hp.com/service/for … Id=1156275


#3

I have tried the fix posted by Albin but it did not fix my problem. I still get the CRC32 error from NRPE. Has anyone found anything else to suggest how this problem might be resolved?