check_nt


#1

I’m using check_nt to verify that a SQL Server instance is running on a remote server, however, I’m having issues configuring the commands,cfg to parse the separate instance. For exmaple:

define command{
command_name check_sqlagent_desperado
command_line $USER1$/check_nt -H $HOSTADDRESS$ -p 1248 -v SERVICESTATE -d SHOWALL -l “SQLAgent$Desperado1”
}

However, Nagios throws an error and constantly says:

Info: check_nt: Unknown argument - (null)

When I check the web interface it says:

SQLAgent$: Unknown

I’ve tried using

“SQLAgent$Desperado1”

and similar permutations to no avail.


#2

As an FYI, there are multiple instances that will be monitored on this server.


#3

Try using two $ symbols instead of one:

“SQLAgent**$$**Desperado1”

I am not sure that it might work, but give it a shot,


#4

thanks, but no luck…


#5

N/M, I got it to work with quotes around the $:

SQLAgent$"$"Desperado1


#6

That’s a new fix for me. Should be a sticky with the subject changed to something like “how to fix an illegal character like the $ in definitions”.


#7

I posted a thread yesterday about how I thought the end of line $ was causing my problems…I tried the above for my entry -> “MSSQL$”$“FHMS” and it solved my problem. So not quite sure how it worked but I’m glad it did :slight_smile: