check_oracle_instance.pl + No Output


#1

hi,

have a problem with check_oracle_instance.pl which returns No Output on execution.
If i execute the command manually as the user nagios as :
[blockquote]/usr/bin/perl /usr/lib/nagios/plugins/contrib/check_oracle_instance.pl -u user -p pass -c SK1 -a[/blockquote] , I get [blockquote]SK1: ok. Oracle9i Enterprise Edition Release 9.2.0.4.0 - Production[/blockquote].
But the same as service is not working.
The commands.cfg entry is :
[blockquote]# ‘check_oracle_inst_act_conn’ command definition active-sessions
define command{
command_name check_oracle_inst_act_conns
command_line /usr/bin/perl $USER2$/check_oracle_instance.pl -u $ARG1$ -p $ARG2$ -c $ARG3$ -a
}
[/blockquote]
where [blockquote]USER2=/usr/lib/nagios/plugins/contrib.[/blockquote]

The services,cfg is :
[blockquote]define service{
use oracle-inst-active-sessions
service_description ORACLE-INSTANCE-ACTIVE-SESSIONS-SeaKey-Staging
contact_groups einsteins
host_name sk1-oradb.mobiapps.com
check_command check_oracle_inst_act_conns!seakey!keysea!SK1
}[/blockquote]

Please help me out in getting this oracle plugin working.

If anyone can guide me how to monitor the clustered oracle instances that would be great

Regards
Prashant


#2

You ran this:
/usr/bin/perl /usr/lib/nagios/plugins/contrib/check_oracle_instance.pl -u user -p pass -c SK1 -a
and it worked, but then you defined this:
check_oracle_inst_act_conns!seakey!keysea!SK1

The 2 are not the same.


#3

hi,

the command worked when from command line as the user nagios with /usr/bin/perl and without /usr/bin/perl hence i gave a shot at the command definition of exluding the /usr/bin/perl. but this gives no output even if you preceed the command with /usr/bin/perl


#4

What he’s saying is that your services.cfg check_command definition is wrong, Prashant.