check_proc


#1

Hi,

I use check_proc and everything is working fine.
The only drawback is that i can only configure one daemon at the time.
Is it possible to check more, different daemons all in one service?

Grz. Johan


#2

No, not with check_procs. Only one check at a time. I do many proc checks myself for about 12 hosts and it really isn’t all that bad to have 30 different proc checks for one host (template config helps). So define a template, and just change the one small entry for each check.

If you really really dislike that, then try check_snmp. With that can have multiple oid’s on one line seperated by a , I think. Of course, you first have to get snmp running on the box you are checking.
Edited Sat Aug 27 2005, 09:39AM ]


#3

Ok, thanks for that.
Another question now we are talking about the subject.
I have the following command:
define command{
command_name check_procs
command_line $USER1$/check_procs -w $ARG1$ -c $ARG2$ -a $ARG3$
}

I check as follows:
check_command check_procs!:1!1:idea:/usr/local/nagios/bin/nagios

This should warn me if it sees more then 1 procs and become ciritical if there are less then 1 nagios daemons.

The strange thing is that that the check sees 2 nagios daemons while there is only one at the system:
2 processes with args ‘/usr/local/nagios/bin/nagios’

When i run the check_proc from the command-line the following happens:

./check_procs -c 1 -w 1 -a /usr/local/nagios/bin/nagios

PROCS OK: 1 process with args ‘/usr/local/nagios/bin/nagios’

How can it be that in the GUI it shows 2 and from the commandline 2?

Thanks again for any reply.

Grz. Johan


#4

Look at your nagios.cfg for this:

MAXIMUM CONCURRENT SERVICE CHECKS

This option allows you to specify the maximum number of

service checks that can be run in parallel at any given time.

Specifying a value of 1 for this variable essentially prevents

any service checks from being parallelized. A value of 0

will not restrict the number of concurrent checks that are

being executed.

max_concurrent_checks=0

If you have it set to 0, like I have, then you could have many many process’ running with the args ‘/usr/local/nagios/bin/nagios’

Do a ps -ef|grep nagios over and over, and you will see that at times, there are many running.