check_smb_shares.pl weirdness


#1

Greetings all,

I seem to be having some trouble with the check_smb_shares plugin
and get the following output on the nagios status info:

directory smb://XXXX/XXXX$/nagios does not exist

The stus is consequently set to unknown and when I run the following
command from a terminal, I get the correct output:


#./check_smb_shares.pl -S FILECOUNT -U nagios -P XXXX -H XXXX -A
XXXX$/nagios -w 1 -c 1 -D XXXX


Correct output:


0 Items (0 Directorys, 0 Files, 0 Links, 0 ) in smb://XXXX/XXXX$/nagios
| ‘FILECOUNT’=0;1;1


This is my command description:


‘check_smb’ command definition

define command{

   command_name    check_smb_shares

   command_line    /usr/lib/nagios/plugins/check_smb_shares.pl -S

FILECOUNT -U nagios -P XXXX -H $HOSTADDRESS$ -A XXXX$/nagios -w
1 -c 1 -D XXXX

   }

I’ve tried a host of things to get it to work including strace’ing
and comparing both the nagios and terminal execution of the command
and there is absolutely no diffference (other than the output/result)

Does anyone have any idea what the problem might be?

–Thanks in advance


#2

Figured it out. The $/XXX was being interpreted by the plugin as a variable.