check_snmp - Cisco PIX 515E OID


#1

I am trying to get CPU stats from my Pix 515E using check_snmp. I have searched high and low for the proper OID.

Cisco website indicates:
1.3.6.1.4.1.9.2.1.58

This of course doesnt return anything. I have tried snmpwalk of the pix and cant find that OID.

The closest I can come is:

1.3.6.1.4.1.9

Which doesnt show anything related to CPU stats. From what I gather from Cisco’s snmp tool the .58 should work. Anybody have any clues for me?


#2

The cpu utilization of pix 515e

the mib : CISCO-PROCESS-MIB

oid : .1.3.6.1.4.1.9.9.109.1.1.1.1.4

name:
.iso.org.dod.internet.private.enterprises.cisco.ciscoMgmt.ciscoProcessMIB.ci
scoProcessMIBObjects.cpmCPU.cpmCPUTotalTable.cpmCPUTotalEntry.cpmCPUTotal1mi
n


#3

Thanks for your help.

I must be missing something…

If I run snmpwalk on my host:
snmpwalk -v 1 -c nagios 192.168.200.1 -On .1.3.6.1.4.1.9.9.109.1.1.1.1.4

I receive the following response:
.1.3.6.1.4.1.9.9.109.1.1.1.1.4.1 = Gauge32: 0

If I try and run check_snmp:
check_snmp -H 192.168.200.1 -C nagios -o .1.3.6.1.4.1.9.9.109.1.1.1.1.4
SNMP problem - No data received from host
CMD: /usr/bin/snmpget -t 1 -r 5 -m ALL -v 1 -c nagios 192.168.200.1:161 .1.3.6.1.4.1.9.9.109.1.1.1.1.4

How does the MIB come into play? I tried running the same check_snmp with -m CISCO-PROCESS-MIB to see if that made any difference but no luck.

What am I missing, thanks again.


#4

I think I have it now…

check_snmp -H 192.168.200.1 -C nagios -o 1.3.6.1.4.1.9.9.109.1.1.1.1.3.1

Returns the 5sec utilization.

Thanks again…