check_snmp missing


#1

Hello Everyone,

I’ve tried already a lot (from downloading snmp plugins, the nagios plugins, net-snmp plugins… and I don’t know what else). I can’t get the check_snmp plugin installed.

I’m running a CentOS 5.1 32bit installation, with nagios 3.0rc2. Other than that, everything is working fine.
I used Net-SNMP-5.2.0.tar.gz, nagios-plugins-setuid-1.4.11-1.el5.rf.i386.rpm, check_snmp_plugins.tar.gz, SNMP_Session-1.11.tar.gz
and even the described perl -MCPAN -e “install Net::SNMP” installation.

This is my /libexec list:
check_apt check_file_age check_log check_oracle check_tcp
check_breeze check_flexlm check_mailq check_overcr check_time
check_by_ssh check_ftp check_mrtg check_ping check_udp
check_clamd check_http check_mrtgtraf check_pop check_ups
check_cluster check_icmp check_nagios check_procs check_users
check_dhcp check_ide_smart check_nntp check_real check_wave
check_dig check_ifoperstatus check_nt check_rpc negate
check_disk check_ifstatus check_ntp check_sensors urlize
check_disk_smb check_imap check_ntp_peer check_smtp utils.pm
check_dns check_ircd check_ntp_time check_ssh utils.sh
check_dummy check_load check_nwstat check_swap

Does anyone know how to do it now… cause I’m running outta ideas…
Might be I’m missing some issue (major or minor)

Thanks in advance,
Danny


#2

I’m having the same problem. I have Ubuntu Server 7.10 installed.


#3

I have search a lot for an answer but I haven’t found any. The only thing is that you have to install:
libsnmp
libsnmp-base
libsnmp-dev
libsnmp-perl
nagios-snmp-plugins &
snmp

I’ll keep searching. Please advice on this.


#4

Hey Guyz,
totally forgot about this, since nobody replied to it either… I solved my issue like this:
download internap.dl.sourceforge.net/sour … 2.4.tar.gz
extract and ./configure… then make and make install. Should do the trick… did it for me at least…

Good luck


#5

I did what you suggested, but again, recompiling the nagios-plugins I got many errors and warning.
I downloaded the nagios-plugins again and recompile them. That fix the entire plugins.

I have now the check_snmp!!!

Thanks