check_winmem


#1

Hi,
I have a problem with the check_winmem,

From th prompt is all OK !

Nagios libexec # ./check_winmem 172.xx.xx.xx public 80 90

OK MEM: usage 59.91 perc - 156088 KBytes of 260528 KBytes -w 80 -c 90

But when I insert the check on nagios configuration in this mode:

     ---- file service.cfg ----

define service{
use 24hNOC
host_name MyHost
service_description Memoria_Ram
check_command check_ram
}

    ----- file checkcommands.cfg ---

define command{
command_name check_ram
command_line $USER1$/check_winmem $HOSTADDRESS$ public 88 95
}

Or this mode:

        ---- file service.cfg ----

define service{
use 24hNOC
host_name MyHost
service_description Memoria_Ram
check_command check_ram!public!80!90!
}

      ----- file checkcommands.cfg ---

define command{
command_name check_ram
command_line $USER1$/check_winmem $HOSTADDRESS$ $ARG2$ $ARG3$ $ARG4$
}

But the result is ever “no output!”

Can someone help me???


#2

Have you checked permissions on the plugin?


#3

Oh ! yess !!
this is permission of my plugin

-rwxrwxrwx 1 nagios nagios 2297 Apr 19 12:29 check_winmem

but the response is always "(No output!)
!sad


#4

OK, so this is what you got?
---- file service.cfg ----

define service{
use 24hNOC
host_name MyHost
service_description Memoria_Ram
check_command check_ram!public!80!90!
}

----- file checkcommands.cfg —

define command{
command_name check_ram
command_line $USER1$/check_winmem $HOSTADDRESS$ $ARG2$ $ARG3$ $ARG4$
}

So, your command would be this:
/usr/local/nagios/libexec/check_winmem MyHost 80 90

Somehow, that doesn’t look right.
I would define the command like this:

define command{
command_name check_ram
command_line $USER1$/check_winmem $HOSTADDRESS$ $ARG1$ $ARG2$ $ARG3$
}

So my command would turn out like this:
/usr/local/nagios/libexec/check_winmem MyHost public 80 90


#5

thanks, i’ve try,
but the result not change .!!! !sad

Always “No Output!”

:frowning:


#6

Are you making sure you restart or reload Nagios after making the config changes?

Sorry, I know it’s basic…just had to ask.


#7

hi,
yes , i’ve reload and restart too my nagios,
the system is already on production with +/- 1.000 check of various type , but this plugin is very
"bip bip bip"
:smiley:


#8

Ste,
I have had the same problem “No output”, looks like the coding of the plugin is not correct. I also tried various options by changing checkcommands and stuff but the same result. I think you should try a different snmp plugin for memory check.


#9

Tried what? Don’t assume that your syntax is correct. Show us that it is correct by pasting the relevant information.