Client not reporting


#1

I


#2

Sounds like you have a misconfiguration in the service definition and it is misinterpretting the port number as some non-integer variable. Pls post your service check object definition and also the command object definition for check_nrpe


#3

I’ve been reading on the subject and let me say that I’m not using NRPE client, I’m using nsclient++ and that’s what I’ve configure… as the quick start documentation says, now been the fact that I’m new to nagios, would you care to explain what is the service definition, and where can I find the check_nrpe entry… thanks for the help…mean while I’m googling around


#4

I know I had a situation where I installed the nsclient++ on an old win2000 Terminal server. I never did get the icon to appear in the system tray but my problem with the reporting was that I had not updates the nagios.ini file on the server. I simply installed it and began troubleshooting. There are several DLL’s that need to be uncommented in order for it to work. I am happy to say that it is now reporting!! Of course, this is the first in what will be a long line of Servers being monitored by nagios.

the journey of a thousand miles begins with one step…

Krubb


#5

I wish I could say the same about mine… mine is not reporting but it’s showing on the system tray…now I see post where ppl are installing the nrpe client and the nagios doc walks you through installing nsclient++ what’s the difference , is the reason ppl go with nrpe is b/c nsclient++ is harder to get working?.. and to answer your question yes I did uncommented the .dll in the ini file…I’ve been reading but other than that don’t know what to do let me say that before deploying to the servers I’m testing it out on a xp machine, hope that doesn’t make any difference

thanks


#6

It would help to see the configuration of the service check you are trying to make, i.e. the one that is showing “status unknown” and


#7

when you install nagios… in what port is spoused to run?..I can login to the web interface, but it’s not getting report back from the clients, all I get is a port error

thanks


#8

[quote=“Strides”]
It would help to see the configuration of the service check you are trying to make, i.e. the one that is showing “status unknown” and [/quote]


#9

and your check_nt command definition in command.cfg looks something like

# 'check_nt' command definition
define command{
        command_name    check_nt
        command_line    $USER1$/check_nt -H $HOSTADDRESS$ -p 12489 -v $ARG1$ $ARG2$
        }

??

The port is specified after the -p parameter, i.e. in the example above it is using 12489


#10

this is what my check_nt definition looks like…

‘check_nt’ command definition

define command{
command_name check_nt
command_line $USER1$/check_nt -H $HOSTADDRESS$ -p password -v $ARG1$ $ARG2$
}

there’s no port define, but how do I know what port should I put here…


#11

ok at the client machine the NSClient++ log is showing

error: .\NSCAThread.cpp 164 << could not connect to: 10.200.50.5: 5667

the ip address in the log is the correct one, but there’s no port open on my nagios machine with 5667 open…I did an port scan and I don’t see any port related to nagios and of course I made sure nagios was running


#12

So if you run check_nt --help you will find that the -p paramater is NOT password, it is port number… -s parameter is password:

 -p, --port=INTEGER
   Optional port number (default: 1248)
 -s <password>
   Password needed for the request

You need to specify the port number as the default for nsclient++, which is 12489 (unless you have altered this in NSC.ini as can be seen in the nsclient++ documentation)