./configure script hangs at "checking for ICMP ping syn


#1

checking for poll… yes
checking return type of socket size… int
checking for /proc/loadavg… found /proc/loadavg
checking for ps… /bin/ps
checking for ps syntax… /bin/ps axwo 'stat uid pid ppid vsz rss pcpu comm args
checking for ping… /bin/ping
checking for ping6… /bin/ping6
checking for ICMP ping syntax…

It has been hung at “checking for ICMP ping syntax…” for the last 20 mins… i have tried it 3 times, but it always hangs there

I am trying to install NagiosPlugins
sourceforge.net/project/showfile … p_id=29880

i have tried all versions too :frowning: they all get stuck at the same point, so it seems like an OS Issue

OS: Ubuntu


#2

Check this screenshot plz
img482.imageshack.us/img482/7214 … ingkm1.png
This is /bin directory

ping and ping6 are highlighted in red
Do you know what that means?

My other Ubuntu PCs don’t have that red highlight on ping and ping6.


#3

The “red” means it has the sticky bit set so that the command can be ran as user “root” by ANY user.
the “s” in the permissions is the sticky bit.
See man chmod for more info.