Could not create external command file


Hi there,

I had a Nagios 3.05 install working about a week or two ago, but since then, I can not get nagios to start. I am running 3.0.6 on Mac OS X Server v10.5.6.

The messages I am seeing in the nagios.log is the following:

[1231183135] Finished daemonizing... (New PID=8638) [1231183135] Error: Could not create external command file '/opt/local/var/nagios/rw/nagios.cmd' as named pipe: (22) -> Invalid argument. If this file already exists and you are sure that another copy of Nagios is not running, you should delete this file. [1231183135] Bailing out due to errors encountered while trying to initialize the external command file... (PID=8638)

I’ve tried deleting the nagios.cmd file and making sure the permissions are correct on the file but no such luck.

Anyone have any ideas on things to try?


Randy Saeks


You have tried to delete the file, and no success? What output error do you get?
You have to stop nagios process in order to delete that file manually.

Be sure you have done permissions exactly as said here:

Be sure you have specified the exact path to command file in nagios.cfg file