Could not read object configuration data!


hi all

I am installing nagios for very first time. After installation and configuration, I have verified using the following command and received no error.
/usr/local/nagios/bin/nagios -v <main_config_file>.

When i point my browser to the nagios, i receive an error as

“Error: Could not read object configuration data!”.

what is the problem ? Is it necessary to compile template based object configuration files ? If yes how to do that ?

Please help me !!! i am trying to rectify this problem for past two days.



sounds like nagios is not running.
ps -ef|grep nagios
or you have bad permissions on your files in nagios/etc


-v is for verification.
Do you start the Nagios service after that?
jakkedup is right with the ps command.


I seriously doubt that he can start nagios, with that error. It sounds like he has tried to start it, but he failed to follow the documentation’s suggestion to FIRST verify your config files. If he had done that first, he would have seen that nagios complains about his config files, and therefor, will not start.


I thank everybody for their great suggestions. Nagios is now working very well, after reinstalling it once again and configuring the plugins properly.

Once again I thank all of you guys.


I have the same issue. I thought it better to keep it all under one thread rather than start a new one.

When I run the “sudo ps -ef|grep nagios” command
I get
"adrian 24846 15493 1 11:00 pts/1 00:00:00 grep nagios"

I followed a guide(ubuntu + Nagios) to get me to this point with a little help from a linux admin who watched over me. I ran the verification command when I was going through the guide and it came up with 0 Warnings and 0 Errors.

This was only today and I thought was nagios was working perfectly till I saw this thread this evening. I had been searching a different topic.
I never set up anything for nagios to actually monitor we the Other admin and I presumed that this Whoops! Error: was due to that.

Could you tell me please what I can do to correct the problem? The other linux admin had only been here on a seperate job and did some things in the middle of the guide that I dont think I can repeat.

Any help would be appreciated


After looking around I found this command
"sudo /etc/init.d/nagios status"

Which threw up
PID 25247
TIME 00:00:00
CMD nagios

After which I found this (by accident after entering in a wrong command)
“sudo /etc/init.d/nagios start”

I then reloaded my browser and lo and behold all the pages came up.
I went into detail incase any other newbie came across this and needed help.

Perhaps someone else could explain what the command “sudo /etc/init.d/nagios status” means. Thanks


etc/init.d/nagios status
Shows the status of that service.
It appears to have been running, but using no cpu time.