Default Directory /usr/local/nagios/


#1

Just out of curiousity, cause i can’t seem to get this thing to run. I have popped all the nagios files under /var/www/ instead. I know all the documentation has said to do everything within /usr/local/nagios/ directory, but I seem to keep coming up with the same prompt to enter credentials.
We are running Red Hat 9.
I have changed the http.conf file to read from this location and created the nagios user and group along with nagiosadmin. Please tell me if I am on the wrong track.
I was getting the same problem when I had everything in the default location so it must be something else I am doing.
Any help would be appreciated at this point.


#2

You need to simply follow the documentation. It is spelled out much more clearly than any of us could possibly do in this forum.
nagios.sourceforge.net/docs/1_0/
yes, you are on the wrong track. There is no reason to change from the default install of /usr/local/nagios
Pay attention to the Setting up the web interface and also the
Authentication And Authorization In The CGIs section.
It’s all there. Every last detail. You should be logged in, after 10 minutes of reading and typing.