Disable SSL certificate check with check_http?


I am monitoring a server that runs a version of apache with a grid middleware stack, not the default apache. This version of apache requires the web certificate it uses to take the form of

http/fully.qualified.host.name instead of just, fully.qualified.host.name

So even though a certificate does exist which matches the hostname, it’s not the cert this instance of apache is looking at. And when check_http runs its check, it fails because the certificate does not match the host name (it is http/hostname). I’m trying to find a way to get around this. The plugin seems to offer no option to ignore such a problem.

I have been able to use the wget command with the “–no-check-certificate” flag which comes close, but I still receive a WARNING due to “no output” Any help is greatly appreciated.