Disabling the nagios2 notifications for a host via web inter


After i installed nagios 2 on my debian linux and added all my host.
I wanted to stop supervising one of my defectuous routers. I tried to disable the notifications via the interface and it didnt works: Error:
Could not stat() command file ‘/var/lib/nagios2/rw/nagios.cmd’!
The external command file may be missing, Nagios may not be running, and/or Nagios may not be checking external commands. An error occurred while attempting to commit your command for processing.

I found solutions for my probleme but still doesn’t working:

+Nagios 2 is not configured to look for external commands in the
+default configuration as a security feature. To enable external
+commands, use the instructions given at
+http://nagios.sourceforge.net/docs/2_0/commandfile.html, replacing
+/usr/local/nagios/var/rw with /var/lib/nagios2/rw and nobody with
+www-data. Then set check_external_commands=1 in
+These commands will set up the permissions properly for a nagios 2
+release candidate. Please verify with the web page quoted above before
+groupadd nagiocmd
+usermod -G nagiocmd nagios
+usermod -G nagiocmd www-data
+mkdir /var/lib/nagios2/rw
+chown nagios:nagiocmd /var/lib/nagios2/rw
+chmod u+rwx /var/lib/nagios2/rw
+chmod g+rwx /var/lib/nagios2/rw
+chmod g+s /var/lib/nagios2/rw

Is anyone have an idea on how i got to proceed for resolving my problem.