DISK CRITICAL - /home/name/.gvfs is not accessible


#1

Hi !

System : Ubuntu Linux 8.10
Nagios version : 3.0.2

I’ve just installed Nagios using APT, on an out-of-the-box Ubuntu 8.10, did nothing special, everything was installed on the bench server without any error
.
I have this message (see subject). I’ve checked allover the web, but didn’t find anything explaining what it comes from, even if i understand that it’s a matter of right.
Did i miss creating a dedicated account for nagios on the server, or is there a parameter to change ? Where should i start looking at ?

I’ll start reading the docs in the days to come, so that i won’t ask too many questions :wink:

Thanks in advance if you can give me any hint !


#2

I found the answer on a forum that was in French. I had to edit the disk.cfg file in /etc/nagios-plugins/config to add 2 extra command options to the command definitions.

# 'check_disk' command definition
define command{
	command_name	check_disk
	command_line	/usr/lib/nagios/plugins/check_disk -w '$ARG1$' -c '$ARG2$' -p '$ARG3$' -A -i '.gvfs'
	}

# 'check_all_disks' command definition
define command{
	command_name	check_all_disks
	command_line	/usr/lib/nagios/plugins/check_disk -w '$ARG1$' -c '$ARG2$' -A -i '.gvfs'
	}

The added options are (see above):

-A -i '.gvfs'

.gvfs is mounted as a file system, so it has to be excluded from the drives checked.