Email got que up


#1

i noticed that whenver there are service down, it doesn’t send email but when I restart sendmail, i received the notification. Does anyone knows how to resolve this problem. It seems that notifications got piled up.


#2

ARe you sure you are restarting sendmail, or it is simply not running, and your restart command is actually starting it for the first time since you have booted. Check it after a fresh reboot of machine.

/etc/rc.d/init.d/sendmail status


#3

im sure it is running and it is not the first time


#4

HI!

I notice that when there is WARNING status, nagios doesn’t send email notification . I check misscommands.cfg and it has -rwxrwxr-x.
I tried to experiment. I use check_user plugins. I configure it when there are 2 user connected, it will become critical. And so I did, but same problem. It still doesn’t send email.
It seems that it is not accurate in sending notification.

Anyone help?


#5

Nagios has no problems with notifications, so please don’t look at this problem like “Nagios is not accurate in sending…” The problem sounds like your sendmail configuration.
Type
su - nagios
then read nagios email, if any
mail
There might be a clue in the emails.