Error after pre flight!


#1

i have no errors or warnings in my pre-flight!but when i enter the following /usr/local/nagios/bin/nagios /usr/local/nagios/etc/nagios.cfg
i get the following errors,can any one please in simply terms please give me a hand as im a little lost.i would appreciate any help
regards
robbie

[root@linux /]# /usr/local/nagios/bin/nagios /usr/local/nagios/etc/nagios.cfg

Nagios 2.0b3
Copyright © 1999-2005 Ethan Galstad (www.nagios.org)
Last Modified: 04-03-2005
License: GPL

Nagios 2.0b3 starting… (PID=1425)
sh: line 1: /check_load: No such file or directory
Warning: Return code of 127 for check of service ‘Current Load’ on
host ‘localhost’ was out of bounds. Make sure the plugin you’re trying
to run actually exists.
sh: line 1: /check_users: No such file or directory
Warning: Return code of 127 for check of service ‘Current Users’ on
host ‘localhost’ was out of bounds. Make sure the plugin you’re trying
to run actually exists.
sh: line 1: /check_ping: No such file or directory
Warning: Return code of 127 for check of service ‘PING’ on host
’localhost’ was out of bounds. Make sure the plugin you’re trying to
run actually exists.
sh: line 1: /check_disk: No such file or directory
Warning: Return code of 127 for check of service ‘Root Partition’ on
host ‘localhost’ was out of bounds. Make sure the plugin you’re trying
to run actually exists.
sh: line 1: /check_procs: No such file or directory
Warning: Return code of 127 for check of service ‘Total Processes’ on
host ‘localhost’ was out of bounds. Make sure the plugin you’re trying
to run actually exists.


#2

or can any1 explain the follwing

Nagios 2.0b3 starting… (PID=2832)
sh: line 1: /check_ping: No such file or directory
Warning: Attempting to execute the command “/check_ping -H 127.0.0.1
-w 3000.0,80% -c 5000.0,100% -p 1” resulted in a return code of 127.
Make sure the script or binary you are trying to execute actually
exists…


#3

it looks like nagios is searching the plugins in the root directory of your server instead of the nagios/libexec directory.

Luca


#4

Luca thanks!i had the path wrong,i have changed the path to be correct,but now when i try start nagios all i get is

Nagios 2.0b3
Copyright © 1999-2005 Ethan Galstad (www.nagios.org)
Last Modified: 04-03-2005
License: GPL

Nagios 2.0b3 starting… (PID=5163)

(and then nothing happens)


#5

Try running ps -A | grep nagios . If anything shows up nagios is running. Also check your web interface (yourserver/nagios/ ) and click on “process info”. If there are no error messages, nagios is running. You can also start/restart nagios by issuing the command /etc/init.d/nagios start or /etc/init.d/nagios restart. If the start command shows a PID, nagios is probably running.

Edit: the command syntax was wrong :o
Edited Tue Jul 19 2005, 07:37AM ]


#6

hey,this is what i got when i ran ps -A
root@linux /]# ps -A
PID TTY TIME CMD
1 ? 00:00:04 init
2 ? 00:00:00 keventd
3 ? 00:00:00 kapmd
4 ? 00:00:00 ksoftirqd_CPU0
5 ? 00:00:00 kswapd
6 ? 00:00:00 bdflush
7 ? 00:00:00 kupdated
8 ? 00:00:00 mdrecoveryd
12 ? 00:00:00 kjournald
67 ? 00:00:00 khubd
159 ? 00:00:00 kjournald
516 ? 00:00:00 syslogd
520 ? 00:00:00 klogd
537 ? 00:00:00 portmap
556 ? 00:00:00 rpc.statd
637 ? 00:00:00 apmd
675 ? 00:00:00 sshd
689 ? 00:00:00 xinetd
703 ? 00:00:00 ntpd
717 ? 00:00:00 lpd
732 ? 00:00:00 rpc.rquotad
737 ? 00:00:00 nfsd
738 ? 00:00:00 nfsd
739 ? 00:00:00 nfsd
740 ? 00:00:00 nfsd
741 ? 00:00:00 nfsd
742 ? 00:00:00 nfsd
743 ? 00:00:00 nfsd
744 ? 00:00:00 nfsd
745 ? 00:00:00 lockd
746 ? 00:00:00 rpciod
752 ? 00:00:00 rpc.mountd
764 ? 00:00:00 safe_mysqld
794 ? 00:00:00 mysqld
805 ? 00:00:00 mysqld
806 ? 00:00:00 mysqld
807 ? 00:00:00 sendmail
817 ? 00:00:00 mysqld
818 ? 00:00:00 sendmail
828 ? 00:00:00 privoxy
837 ? 00:00:00 gpm
848 ? 00:00:01 httpd
857 ? 00:00:00 crond
936 ? 00:00:00 xfs
943 ? 00:00:00 httpd
944 ? 00:00:00 httpd
945 ? 00:00:00 httpd
946 ? 00:00:00 httpd
947 ? 00:00:00 httpd
948 ? 00:00:00 httpd
949 ? 00:00:00 httpd
952 ? 00:00:00 httpd
953 ? 00:00:00 smbd
957 ? 00:00:00 nmbd
974 ? 00:00:00 winbindd
992 ? 00:00:00 atd
1007 ? 00:00:00 rhnsd
1037 ? 00:00:00 nagios
1041 tty1 00:00:00 mingetty
1042 tty2 00:00:00 mingetty
1043 tty3 00:00:00 mingetty
1044 tty4 00:00:00 mingetty
1045 tty5 00:00:00 mingetty
1046 tty6 00:00:00 mingetty
1047 ? 00:00:00 gdm-binary
1050 ? 00:00:00 nagios
1052 ? 00:00:00 nagios
1103 ? 00:00:00 gdm-binary
1104 ? 00:00:05 X
1117 ? 00:00:00 gnome-session
1191 ? 00:00:00 ssh-agent
1194 ? 00:00:00 gconfd-2
1196 ? 00:00:00 esd
1205 ? 00:00:00 bonobo-activati
1207 ? 00:00:00 metacity
1210 ? 00:00:00 gnome-settings-
1213 ? 00:00:00 fam
1220 ? 00:00:02 gnome-panel
1222 ? 00:00:01 nautilus
1224 ? 00:00:00 magicdev
1227 ? 00:00:00 pam-panel-icon
1229 ? 00:00:04 rhn-applet-gui
1230 ? 00:00:00 pam_timestamp_c
1239 ? 00:00:01 gnome-terminal
1240 pts/0 00:00:00 bash
1278 ? 00:00:00 squid
1280 ? 00:00:02 squid
1281 ? 00:00:01 unlinkd
1294 pts/0 00:00:00 ps

also i can get up my web interface i followed the doc’s must of when wrong somewhere


#7

1037 ? 00:00:00 nagios

nagios IS running… do you get a prompt after starting nagios?

Luca


#8

no, no promt !


#9

anything in the logs? nagios, httpd. or syslog?


#10

Luca,
thanks for your help,nothing comes up unfort. have u any suggestions?


#11

this is what is in the log

[1121853724] Nagios 2.0b3 starting… (PID=1628)
[1121853724] LOG VERSION: 2.0
[1121853724] Lockfile ‘/usr/local/nagios/var/nagios.lock’ is held by
PID 1611. Bailing out…


#12

can any1 tell me how to remove selinux please?


#13

i think there was something recently… try a search on the forum.

Luca


#14

what path is yout httpd.conf file in?


#15

what path is your httpd.conf file in?


#16

what path is your httpd.conf file in?


#17

the httpd.conf is in the apache directory. depends from your system, it usually is in /etc/apache or /etc/httpd.
you should find it making a serach on the file system usign “whereis” or “find”.

Luca

PS: go one problem after the other, it makes not much senese working on the httpd.conf and se linux at the same time, first remove SELinux (which is known to give rpoblems with nagios from what i0ve seen on this forum)
Edited Wed Jul 20 2005, 06:53AM ]


#18

cool, will do,really appreciate your help luca,cheers!


#19

[quote=“glynner”]this is what is in the log

[1121853724] Nagios 2.0b3 starting… (PID=1628)
[1121853724] LOG VERSION: 2.0
[1121853724] Lockfile ‘/usr/local/nagios/var/nagios.lock’ is held by
PID 1611. Bailing out…[/quote]

That tells you that you are triing to start nagios, but nagios is already running.

Stop nagios
/etc/rc.d/init.d/nagios stop
ps -ef|grep nagios
Make sure that they are all dead, if not, kill them until the grep shows no nagios running.
Reboot your puter if you have to but kill them all FIRST.
Then use the -v again and make sure your config files are correct this time, before you attempt to start nagios. If you have rebooted, nagios will most likely already be started automatically, so use -v before you reboot.


#20

thank you very very jakkedup.appreciate the mail!!