Error starting nagios service


#1

Hello!!

I have installed and configured nagios (as far as I can see…), but when I try to start the service, I get an “su bash/bin: access denied” message.
Can anyone tell me why?

I have tested the nagios config with the -v option, but no errors show up.

Is this error the reason for why I don’t get any cgi-bin script in my browser? e.g …nagios/cgi-bin/status.cgi. When I try to access these links, I get an “Internal server error” in the browser…

I am really frustrated over this. I have worked on this for a week now…

:cry:


#2

how do you attempt to start the service?
The best thing to do, would be to start at the docs page 1, and do it step by step all over again.
Pay close attention to the output from your ./configure too. AFter you run make, there are other make options and hints, so read that make output.


#3

I’m starting nagios with /etc/inid.d/nagios start… -I’m running Fedora Core 4

I have gone through all the steps in the docs for installing nagios several times, but can’t manage to figure it out. I see now that Nagios is starting, but I still get this “su bash/bin access denied” message…

:expressionless:


#4

su bash/bin? I think you compiled wrong, that’s why I suggest to start over. from source.


#5

FC4?
Check SELinux is disabled on httpd (check one of the latest threads as to the exact definition…).
retry

Luca