(fedora) install went ok but


#1

I followed the ‘15min’ install page for Fedora and all the steps completed AFAIK.
When I load the nagios web page I am prompted for authentication - and enter nagios/pwd (as defined during install) - but it is rejected: A username and password are being requested by 127.0.0.1. The site says: “Nagios Access”

I also notice there are 9 httpd processes - which seems wrong. I had not been using apached (service off) until the nagios install.

Any suggestions? ** Thanks**


#2

I’m not using feodora,
but I think I can help.

First check what your admin account for nagios is.
Normally that is nagiosadmin (i think),
Then set the password for this accoutn using

htpasswd -c /usr/local/nagios/etc/htpasswd.users nagiosadmin

Then try logging in again,

If you’re unsure what you admin account for nagios is you can check,

/usr/local/nagios/etc/object/
Ithink it’s in template.cfg og hosts.cfg.

good luck


#3

thanks - that was the problem/solution… the only account I setup during install was ‘nagios’ and changing that password let me get it.

After getting in to nagios I now get “It appears as though you do not have permission to view information for any of the hosts you requested…If you believe this is an error, check the HTTP server authentication requirements for accessing this CGI and check the authorization options in your CGI configuration file.” I should be able to figure this out - but wish the quick install instructions included info on this.