Floating Point Exception with the Nagios binary


#1

Noon people.

Anyone recognise this?

nagios:/usr/local/nagios# bin/nagios -v /usr/local/nagios/etc/nagios.cfg
Floating point exception

nagios:/usr/local/nagios/bin# ./nagios
Floating point exception

It seems I cant use the binary on any purpose, and all I get is this Floating Point Exception.
The only thing I’ve done is to install Nagios through the ‘Ubuntu Quickstart Guide’.

I tried installing it on a different physical server, still the same error at the same point.
Anyone got a clue?

I’m just running the localhost.cfg right now in debuggingpurposes wich is standard.

PS. nagios.cfg following beneath .DS

Best Regards
Lars Engstr


#2

Splendid, got it working again.

Ofcourse, the problem was with me messing everything up.
I copied the whole /usr/local/nagios directory from my dev-machine straight off, instead of just copying the /usr/local/nagios/etc folder, wich I thought I did.

All good, thank you in advance. :slight_smile:

Best Regards


#3

For those who stumble upon this thread through Google and who’re having the same kind of trouble, the same goes for the basic plugins (Those who needs to be compiled) - they’ll all give a " (Return code of 136 is out of bounds) " if a “Floating Point Exception” occurs, hence why nothing gets found on google if you’re searching for the 136th error code.

Best of luck!