Got some issues with installation of NRPE_plugin


#1

Hi, All,

I’ve got some issues when tried to install NRPE_plugin (or addon) on a ngios monitor host.

The server on which I wanted to get NRPE_plugin run has been installed and configured with Nagios 3.2.1 and Centreon 2.1.8, and both of them ran okay. BTW, the OS of the server is Ubuntu 8.04 LTS.

I followed the procedures described in the NRPE.pdf, and what I had done included:
cd /usr/local/src
wget package of nrpe-2.12
untar
cd nrpe-2.12
./configure
make all
make install-plugin

Then,
cp /usr/local/src/nrpe-2.12/src/check_nrpe.c /usr/local/nagios/libexec/check_nrpe
chmod a+x check_nrpe

When I tried to execute /usr/local/nagios/libexec/check_nrpe -H , I got the followed messages:
line 1: /bin: is a directory
line 2: centreon.conf: command not found
line 3: centreon.conf: command not found
line 4: syntax error near unexpected token (' line 4: * Copyright © 1999-2008 Ethan Galstad (nagios@nagios.org)’

Actually, I even couldn’t find the stuffs like ‘/bin’ or ‘centreon.conf’ in the check_nrpe.c file, so don’t know where these errors came from.

This was the first time I tried to install and configure Nagios and the frontend, and this error really confused me. Could anybody give me some help with that?

I really appreciate it if anyone have time to read this mail and provide me some advices.

Regards