Help: Unable to Start Nagios - Getting Undefined Variable Er


#1

Nagios Ver & OS Ver: Running Nagios 3.0.2 on OpenSUSE 10.3
Problem: I am in the process of implementing Nagios for the first time. I installed Nagios and successfully started it after following the Quick Startup Guide for OpenSUSE. I then shutdown Nagios and modified the nagios.cfg file by commenting in [activating] the windows.cfg configuration line. I restarted Nagios, but it failed to start. :frowning:
I then restarted Nagios using the verification -v switch, which reported an “Undefined Variable” error on the following nagios.cfg file line (the line defining the temp_path):
[blockquote]# TEMP PATH

This is path where Nagios can create temp files for service and

host check results, etc.

temp_path=/usr/local/nagios/var/tmp[/blockquote]

The permissions for the *tmp *directory are as follows:
[blockquote]drwxrwxr-x 2 nagios nagios tmp[/blockquote]

I have tried moving the *tmp *directory back to its default location to /tmp to see if that made a difference — it did not — still get the same error.

I then commented out this *tmp *line of code and reran the nagios -v verification tool. This time I received the same error [Undefined Variable], but for a different line of code called:
[blockquote]check_result_reaper_frequency=5[/blockquote]

Does anyone have any idea what’s going on? Could I possibly have a corrupt nagios.cfg file? Should I just upgrade to the newer version of Nagios that was just released?

Thanks in advance for your help!


#2

Unpack the original nagios.cfg and do the diff to see the differences. Maybe something is misconfigured. If you can’t see any errors manualy try to copy original nagios.cfg to your Nagios installation and see if it works.