Help with basic Nagios Configuration!


#1

Hello all,

I have installed Nagios on a SUSE 10.3 machine. After configuring the configuration files, I still have not recieved any visual results form te webinterface. Here is a picture to show what I mean:

http://img409.imageshack.us/my.php?image=unbenanntcp2.png

Do I have to configure CGI with the following options in the Nagios config file:

*you can also tell Nagios to process all config files (with a .cfg
extension) in a particular directory by using the cfg_dir
directive as shown below:

#cfg_dir=/usr/local/nagios/etc/servers
#cfg_dir=/usr/local/nagios/etc/printers
#cfg_dir=/usr/local/nagios/etc/switches
#cfg_dir=/usr/local/nagios/etc/routers
*

I have the other config files configured, so I enable these so nagios will display results on the webinterface, or is there something different that I have yet to configure?


#2

I figured it out!!!


#3

Can you share your solution with us? 8)


#4

[quote=“evert”]
Can you share your solution with us? 8)[/quote]

Yeah sure, what I had done after installing nagios, is I got onto the webinterface and saw nothing displayed on the webinterface such as the link above in my first post. I ended up configuring the .cfg files and ran the check in the linux terminal to check that I had configured everything. It was ok with no errors, so I refreshed the nagios page thinking it would automatically load the results. All I had to do was reload nagios and it worked beutifully. The command I ran for that (under linux that is) was:

/etc/rc.d/init.d/nagios reload

That was it and it works now!!! :frowning: