Histogram.cgi statusmap.cgi trends.cgi not working


Hello everyone !!!
First time Nagios user/installer here.
Went through all the manuals and a lot of posts here before posting but i did hit a wall.
Nagios itself compiled fine and so did the plugins.
Got the web interface to work and fired up the sample localhost config just fine.
Out of all the CGIs only the three mentioned in the topic are not working.
Did ‘ldd’ on all three and saw no problems.
I installed all the required libraries but i’m still getting the dreaded :
ld.so.1: statusmap.cgi: fatal: libgd.so.2: open failed: No such file or directory, referer:
[error] [client] Premature end of script headers: statusmap.cgi, referer:

I tried this with 3 different web servers (apache 2.0.59, apache 2.2.x and IBMIHS61).
I do have the gdlib installed in /usr/local/lib and the ./configure script for Nagios does find it. At least it says it found it.

I’m on Solaris 10 SPARC.

Any ideas/suggestions are very welcome as i really don’t know what else to look at.

If you need any output - let me know and i’ll post it.

Thanks in advance,


Well, it looks like i’ll be answering my own question…

I DID IT !!!

As a last resort i decided to try this: bwachter.lart.info/solaris/solfaq.html
Configuring the Dynamic Linker.

I’ve added the /usr/local/lib to the default path (it wasn’t there) and re-configured, re-made, and re-installed Nagios.
Bounced the web server and - BAM - its working…

I can’t believe my eyes !!!


Wow! Thank you for posting an answer to your own problem! You probably saved me hours worth of work.

I too just installed Nagios on a Solaris 10 box, and after hours of working to make it run in Solaris I was so frutrated when I started seeing errors on several pages. I ran into this error when trying to look at the map and a few other pages. It was the only thing I couldn’t seem to figure out, as I had /usr/local/lib my LD_LIBRARY_PATH environment variable. Nagios is difficult to get working on Solaris SPARC (took me 15 minutes to get up & working in Ubuntu), but now I think it’s finally working as it should. Now I can finally start working on setting up monitoring services.

Simply running the command “crle -l /lib:/usr/lib:/usr/local/lib” fixed it for me. I didn’t even have to recompile.

If you don’t mind me asking an unrelated question, have you found check_by_ssh or NRPE to be more beneficial for monitoring Solaris systems? I could use either one, but I’m leaning towards check_by_ssh since that seems like it might be more convenient.

Thanks again!