Host Status Totals is blank


#1

Hello.
I am having a problem with Service Details section. When i click on service details my “Host Status Totals” is showing all 0 for Up,Down, Unreachable and Pending, even though i have hosts added to nagios and i can see the Service Status Tool to be working fine.
Please help,
thanks


#2

How about with the other cgis? Is the totals blank too?


#3

I think there is more that one nagios running.
stop all nagios process and try again. Verify you configs first.


#4

I have verified that only one process of nagios is running. I have also restarted the machine. All the other cgi’s are working fine. Only the part of Host Status Tools is showing incorrect numbers. It should show something like Up-25, Down-2,etc. but all the numbers are zero. If i click on Up or Down, it shows the hosts which are up or down but the numbers are still appearing zero. All the other cgi’s are working fine. The Service Status Tools, which is right next to Host Status Tools, is showing the right numbers.


#5

authorized_for_all_services=
Check your cgi.cfg and make sure that you have given yourself access.
Check the permission on the var/ directory and files inside of it.
Go through the entire install again by reading the docs and following them step by step. If after that, you still don’t have it, then we can try again.


#6

Are you using database or files for storage of this info?
paste your src/nagios-1.2/config.status that has the ./configure switches like I did below.

This is mine:
./configure --with-mysql-comments --with-mysql-status --with-template-extinfo --with-mysql-retention --with-template-objects --with-mysql-downtime --with-mysql-lib=/usr/lib/mysql --with-mysql-inc=/usr/include/mysql
It could just be that you have no data due to how you compiled nagios.
Edited Fri Jul 08 2005, 01:23PM ]


#7

Sir,
Yes the problem is solved. Thank you so much. I am glad to know that i am getting help from the experts.
I appreciate your help once again.
Regards,


#8

So what was the fix?


#9

Sorry, for the late reply. I have been out of town for a few days. The above problem was solved when i went through the cgi.cfg and found that it was a very small mistake in the name of the id. Thanks :slight_smile: