How to disable active checking of some services in distribut


#1

Hello,

in the documentation of 1.x i can read:

If you’re using the central server to actively monitor a few services on >its own (without the aid of distributed servers), the >enable_active_checks option of the defintions for service being >monitored by distributed servers should be set to 0. This will prevent >Nagios from actively checking those services.

Now in which config file on the Nagios central server do I have to set “enable_active_checks” to 0 of the service which has to be checked passively only.
services.cfg does not work: Nagios bails out with error: “Error: Could not add object property in file ‘/etc/nagios/services.cfg’ on line 465.”

I can’t disable active checking completely, because Nagios has to monitor some services actively.

Any hints would be appreciated.
Thx, Thomas


#2

On the central nagios server define in services.cfg
passive_checks_enabled 1
active_checks_enabled 0
for all services that are not being actively checked.
The remote host is just the opposite.