HTTP WARNING: HTTP/1.1 401 Authorization Required


#1

Hello
i just installed nagios on a new centos 5.4 server and in the service status details we have this warning (HTTP WARNING: HTTP/1.1 401 Authorization Required) can someone give me some insite on this please


#2

you didn’t follow the instructions correctly. You have to setup uthentication correctly.

nagios.sourceforge.net/docs/3_0/quickstart.html


#3

Hello
Well i dont know witch step i missed cause i followed the fedora quick start to a T. can you point me in the correct direction please


#4
  1. Configure the Web Interface

i’d point on a missing htpasswd file or the config relative to the htpasswd file in the apachec config


#5

hmmm

i configured that also. when going to the nagios control panel it does ask me for my user name and pass


#6

ok, try checking the apache logs if there’s some clue about what may be wrong.


#7

I did find this

Fri Feb 26 01:01:21 2010] [error] [client xxx.xxx.xxx.xxx] user nagiosadmin: authentication failure for “/nagios”: Password Mismatch

so do i just redo the htpasswd step

also if the password was mismatched why did it still let me in


#8

is it working now?

if it was a password problem it shouldn’t have let you to the main nagios page…


#9

[quote=“luca”]is it working now?

if it was a password problem it shouldn’t have let you to the main nagios page…[/quote]

No inputing a new pass DID NOT fix it. i am at a loss here


#10

same here…

happy it was fixed… but it’s quite strange… oh well… glad you came out of it and sorry for the first post :slight_smile:


#11

oops typo

No it is not fixed. reinputing the password did not fix it


#12

have you tried remaking all three steps in point 5?


#13

Hello

well i did all the steps of step 5. and no change


#14

try turning selinux off…


#15

its been disabled and has been


#16

no ideas left, apart from a complete nagios reinstall, something must have gone wrong… but i can’t say what. sorry.


#17

OK thats not a problem. but i am not sure how to ?


#18

delete the files you downloaded and the file create dby the make commands, and delete the installed files… then redownload and start again by the instructions… hoping it helps :wink:


#19

what is the (dby file


#20

created by :slight_smile: