Httpd.conf verification


#1

when I go browse to my nagios server, it is simply showing the directory listing instead of pulling up the index.html page for nagios. Below is my httpd.conf file. I would like for someone to verify this as I am pretty sure the settings are not correct:

ScriptAlias /nagios/cgi-bin “/usr/local/nagios/sbin”

<Directory “/usr/local/nagios/sbin”>
Options +ExecCGI
AllowOverride None
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user

Alias /nagios/ “/usr/local/nagios/share”

<Directory “/usr/local/nagios/share”>
Options +ExecCGI +FollowSymLinks +Indexes
AllowOverride None
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user

Thanks in advance.


#2

Hi

Try
Alias /nagios "/usr/local/nagios/share"
Also, confirm you have:
DirectoryIndex index.html

HTH

/S