Installation problem



OS: fedora 5
nagios version: 2.9
nagios plugin: 1.4.8

I downloaded the current stable source of nagios and tried to install it using the quick configuration guide, i followed it fervently but when i reached the make install-webconf portion, i got stuck and received this error ->
make: *** No rule to make target `install-webconf’. Stop.

then i proceeded to install the plugins just the same and added the nagios service and started it and did not encounter any errors but when i try to browse localhost/nagios all i got was a http 404 not found page.

please help.



I’m having the same exact issue right now. I installed it on a laptop just to go thru it, and it worked perfectly. I installed in on the machine that will be hosting nagios for our monitoring and I got that same error. What the heck??


I already solved the problem, apparently the make install-webconf script does not do what is supposed to do i.e., to add the scriptalias to your httpd.conf. you have to manually add it to make it work.


I figured it out as well. I used this method. I copied the sample-config/nagios… to the /etc/apache2/conf.d directory (paths escape me right now, if needed I will post them definitely) Once that was done, I restarted apache, and Nagios worked perfectly!


We are seeing the same issue. This is what we’re using:

OS: fedora6
nagios version: 2.9
nagios plugin: 1.4.8

I think I followed the above logic, so I did this:

cp sample-config/httpd.conf /etc/httpd/conf.d/nagios.conf

It copied the file over.

I then did this:

make install-webconf

and it came back with the error:

*** No rule to make target `install-webconf

Help! :frowning:

Did I copy the file to the wrong place? Any help offered would be greatly appreciated. Thanks!


update to version 3.0a2 for the fix I used to work. It is using a different folder schema.


fedora 6
nagios version 3.0 a4
nagios plugins 1.4.7
hy guys i have a same problem i received the error when i trie to make install-webconf.
i tried aswell to add manually a script config at the end of httpd.conf file but doesn’t work…
someone solve a problem???